ドローン送信 (どろーんそうしん) *

カテゴリ

nadesiko3-drone > ドローン

環境

cnako

種類

関数

引数

CMDを|CMDの

説明

コマンドをドローンに送信する

# [拡張プラグイン] 以下の宣言が必要:
!『nadesiko3-drone』を取り込む

→『ドローン送信』を貯蔵庫で検索

簡単なサンプル *

ドローンにコマンドを送信します。以下はバッテリーの残量を調べる「battery?」コマンドを送信する例です。

!「nadesiko3-drone.js」を取り込む

「接続を開始しています」と表示。
ドローン接続

ドローン接続した時には
  「✈接続しました」と表示。
  「バッテリを確認します。」と表示。
  「battery?」をドローン送信。
ここまで

ドローン受信した時には
  N=対象をトリム
  「✈受信:【{N}】」を表示
  もし、N="ok"ならば戻る
  終わる。
ここまで

参考 *

Konawiki3 v.3.2.3